Flow Rate values not on AeroGCS Green

YF-S401 flow rate sensor flow rate values are not being shown on the aerogreengcs, the consumption value are though shown, it is connected to cube using AUX 5, the parameter values are


Hello @Karandeep ,
Thanks for posting. Can you please check the SERVOx_FUNCTION pin value. SERVOx_FUNCTION = -1 (AUXx where sensor pin is attached) (SERVO13_FUNCTION should be set to -1 if sensor pin is attached to AUX 5).
If the flow sensor values are shown and flow rate is not showing then can you please share the screen recording or screenshot for the same. Also please share the build number of AeroGCS GREEN app in which the issue is occuring.

1 Like

i am not able to show the videos, as i am not allowed the error is not resoloved all the values being used are the values suggested by Aerogcs. even then the flow rate is not being shown only flow consumed is shown. even gave alternate power to flow sensor then also only consumed rate is being shown.

Does this issue occuring only on one drone or have you tried it on any other drone too. Means can you please try by changing the flow sensor ? Also if possible please share the build number of AeroGCS GREEN app. It will help us to check on our side.

Well it is currently happening on this drone only others are fine. And the flow senor we haven’t changed yet cause we are getting the flow consuming or consumed values on the app, which means i guess that the sensor is working. The version for app v 1.39 .

Processing: 1000012583.jpg…
As you could check herer that only consumed values is shown, now the flow rate is not being shown, not able to do much for flow rate.
The setting are done as guided

Build number 67.175.20240101.01 for app

Okay @Karandeep …The screenshot is not visible. Also can you please check by changing the flow meter. It will be easy to identify the issue.

Sir, we have change the flow meter multiple times earlier there was other model used and then nothing was being shown. Now in this one we are getting Consumed rate only not the flow rate. Sharing the screen shots agian check if visible

Hello @Karandeep ,
We took flight yesterday on same version and build number on our spraying drone. We are getting the values of consumed liquid and flow rate. We are also using same flow meter. Can you please tell did you test it in autonomous mode or manual mode ? Please check the attached screenshot.

Yes, sir checked the screenshot, the flow rate is visible on your flight,
We basically had the manual flights so far, all the flights that has been performed were manually

Is there error in manual mode only that the flow rate would not be visible ( i am guessing as you mentioned about the autonomous flight).
How could these values be visible on manual mode also (well currently we haven’t even done a auto flight so cannot confirm that the rate would be visible in auto mode, just asking if we want at manual mode then it would not be shown? )

So could you help us little bit more to understand this error sir, actually tried even giving extenal direct power source also no success

Try in autonomous mode as well if it is shown in autonomous mode. We will check the same thing in manual mode and confirm you the same.

Sir, we tried the Drone in autonomous mode, we are getting our flow values in autonomous mode, but in manual mode the values are not being shown for flow rate only consumed rate is being shown, so i guess it is a issue of software ? if i am not wrong, any solutions could be provided ? , As sometimes auto flight is not done and flight is done in manual mode so, the flow rate value is required for that type of usecases. if any solution is there please let me know sir.

Yes we are working on it. It will be available soon.

This issue is resolved now, Please update the playstore build and check it. The flow rate is visible in manual mode.

Okay sir, will do a flight test and give you a confirmation from my side, or any errors faced